Inter-VLAN Routing

A. Pengantar

VLAN (Virtual Local Area Network) berguna untuk membagi broadcast domain, pembagian dilakukan tanpa memperhatikan lokasi dari sisi dimana perangkat ditempatkan. Pada kesempatan ini akan dibahas mengenai routing pada router dengan VLAN yang berbeda. Perlu diingat bahwa satu VLAN adalah satu alamat jaringan sehingga memiliki satu broadcast domain juga. Karena VLAN bekerja pada layer 2 OSI maka dibutuhkan perangkat layer 3 untuk menghubungkan VLAN yang berbeda.

B. Topologi

Dalam topologi ini terdapat dua buah VLAN yaitu VLAN 10 dan VLAN 20, supaya kedua VLAN dapat berkomunikasi maka ditempatkan sebuah router cisco sebagai gateway masing-masing VLAN.

picture53

C. Konfigurasi

PC-VLAN 10:

picture29

PC-VLAN 20:

picture37

SWITCH:

PC-VLAN 10 terhubung pada port fa0/2, PC-VLAN 20 terhubung pada port fa0/3, ROUTER terhubung pada port fa0/1.

Membuat VLAN:

Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#name Departemen-IT
Switch(config)#vlan 20
Switch(config-vlan)#name Departemen-HRD

Mendaftarkan VLAN 10  pada interface fa0/2:

Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Mendaftarkan VLAN 20  pada interface fa0/3:

Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20

Mendaftarkan VLAN 10 dan 20 pada interface fa0/1:
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk

ROUTER:

Pada router terdapat dua buah interface, fa0/0 digunakan untuk ISP jadi untuk sisi jaringan local hanya menggunakan interface fa0/1. Karena VLAN yang digunakan ada dua maka maka harus menggunakan subinterface supaya masing-masing VLAN memiliki interface. Supaya subinterface berjalan maka router harus mendukung protokol VLAN trunking 802.1Q untuk melakukan enkapsulasi 802.1Q.

Router(config)#interface fastEthernet 0/1.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config)#interface fastEthernet 0/1.11
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.2.1 255.255.255.0

Perlu diingat bahwa setelah command encapsulation dot1Q adalah VLAN ID yang didaftarkan di switch.

D. Testing Routing

Cek tabel Routing:

Router#SHow ip route
Gateway of last resort is not set
C  192.168.1.0/24 is directly connected, FastEthernet0/1.10
C  192.168.2.0/24 is directly connected, FastEthernet0/1.11

Test Ping dari IP Address 192.168.1.2 :

picture43

Sampai disini inter-vlan routing sudah berjalan dengan baik.

This entry was posted in Networking. Bookmark the permalink.

5 Responses to Inter-VLAN Routing

  1. hasan says:

    switch (config) dan router (config) itu 1 OS atau 2 OS ?
    pakai OS apa?

  2. 1100060884 says:

    Beda dong mas, soalnya perangkatnya sudah beda. kalau dalam hal ini OS nya sudah bawaan dari perangkatnya.

  3. sudar says:

    mas saya mau tanya gimana caranya membatasi routing…

    contoh kasus saya punya 4 vlan
    vlan 1
    vlan 2
    vlan 3
    vlan 4

    nah saya mau routing vlan 1 ke vlan 3

    trus vlan 2 ke vlan 4

    untuk kasus seperti ini routingnya gimana mas ?

  4. prakoso yoga says:

    mantap mas bero, SUKSES!! 😀

  5. oecil69 says:

    terima kasih bang atas ya. misalnya saya ingin menyayakan tentang pembahasan VLAN boleh atau tidak bang????

Leave a Reply

Your email address will not be published. Required fields are marked *