Membagi Bandwidth Lokal dan Internasional dengan Mikrotik

1.Pengantar
Pemisahan bandwidth untuk trafik internet Indonesia (OpenIXP dan IIX) dan untuk trafik internet internasional sangat diperlukan, karena biaya untuk penggunaan bandwidth internasional jauh lebih mahal dari lokal. Menurut saya mikrotik sekarang sudah sangat bagus, disamping harga yang murah juga menyediakan fitur yang banyak. Dalam pembahasan kali ini interface keluaran dari router mikrotik untuk tujuan link internasional dan IIX adalah satu.

2. Topology
Topologi yang digunakan dalam pembahasan dalam kasus ini adalah :

picture111

Untuk sisi LAN diberikan IP Address gateway 10.200.16.13/25
Untuk sisi WAN diberikan IP Address gateway 202.51.107.121/26

3. IP NAT
Karena klient menggunakan ip private maka dilakukan NAT seperti yang sudah saya jelaskan pada tulisan NAT pada router Mikrotik.

picture32

4. Pengaturan IP Address List
Mulai Mikrotik RouterOS versi 2.9, dikenal dengan fitur yang disebut IP Address List. Fitur ini adalah pengelompokan IP Address tertentu dan setiap IP Address tersebut bisa kita namai. Kelompok ini bisa digunakan sebagai parameter dalam mangle, firewall filter, nat, ataupun queue.
Mikrotik Indonesia telah menyediakan daftar IP Address yang diadvertise di OpenIXP dan IIX, yang bisa didownload dengan bebas di URL: http://www.mikrotik.co.id/getfile.php?nf=nice.rsc
File nice.rsc ini dibuat secara otomatis di server Mikrotik Indonesia setiap pagi sekitar pk 05.30, dan merupakan data yang telah di optimasi untuk menghilangkan duplikat entry dan tumpang tindih subnet. Saat ini jumlah baris pada script tersebut berkisar 430 baris.
Contoh isi file nice.rsc :
add list=nice address=”114.120.0.0/13″
add list=nice address=”114.56.0.0/14″
add list=nice address=”125.166.0.0/15″
add list=nice address=”125.162.0.0/16″
add list=nice address=”125.163.0.0/16″

Hati-hati dalam menyimpan file nice.rsc, caranya adalah : setelah dibuka di web browser file ->save page as ->file name=nice ->save as type=text document

5. Simpan file nice.rsc ke router mikrotik lewat FTP
Pastikan file nice.rsc sejajar dengan tempat anda mengakses ftp. Dalam kasus ini file nice.rsc disimpan di folder C:\>

picture42

Untuk keluar dari ftp ketikkan ftp>bye

6. Import file nice.rsc

picture52Pastikan sudah berhasil dengan menggunakan aplikasi winbox dan cek menu address list pada firewall

picture62

Jika Anda menggunakan RouterOS versi 3.x, proses update juga dapat dilakukan secara otomatis.
Perintah yang perlu dibuat adalah :

/system sched add comment=”update-nice” disabled=no interval=1d name=”update-nice-rsc” on-event=”:if ([:len [/file find name=nice.rsc]] > 0) do={/file remove nice.rsc };/tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc;/import nice.rsc” start-date=jan/01/1970 start-time=00:06:00

picture74

7. Pengaturan Mangle
Kita perlu membuat 1 buah connection mark dan 2 buah packet mark, masing-masing untuk trafik internasional dan lokal. Aturannya adalah sebagai berikut :
#0 chain=prerouting in-interface=ether-local dst-address list=nice action=mark-connection new-connection-mark=conn-iix passthrough=yes

#1 chain=prerouting connection-mark=conn-iix
action=mark-packet new-packet-mark=packet-iix
passthrough=no

#2 chain=prerouting action=mark-packet
new-packet-mark=packet-intl passthrough=no

Supaya lebih mudah mari kita buat lewat aplikasi winbox pada menu firewall  mangle

picture8

Untuk rule #0, pastikanlah bahwa Anda memilih interface yang mengarah ke client. Untuk chain, menggunakan prerouting, dan untuk kedua packet-mark, kita menggunakan passthrough=no.

8. Pengaturan Simple Queue
Untuk setiap client, kita harus membuat 2 buah rule simple queue. Pada contoh berikut ini, kita akan melakukan limitasi untuk IP client 10.200.16.15/32, dan kita akan memberikan limitasi iix (up/down) sebesar 64k/256k, dan untuk internasional sebesar (up/down) 32k/128k.

Settingannya adalah sebagai berikut :
#0 name=”PC-A-IIX” target-addresses=10.200.16.15/32 dst address=0.0.0.0/0 interface=all parent=none packet-marks=packect-iix direction=both priority=8 queue=default-small/default-small limit-at=128000/128000 max-limit=256000/256000 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small

# 1 name=”PC-A-Intl” target-addresses=10.200.16.15/32 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=packect-intl direction=both priority=8 queue=default-small/default-small limit-at=1000000/1000000 max-limit=2000000/2000000 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small

Supaya lebih mudah gunakan aplikasi winbox masuk ke menu Queues:

picture9

9. Test bandwidth
Dari kasus diatas bahwa bahwa IP 10.200.16.15 akan mendapatkan bandwidth :
IIX minimum=128 K, IIX maksimal=256 K
Internasional minimum= 1 M, maksimal=2M

Test IIX

picture10

Test Internasional

picture112

Sudah sesuai , selamat mencoba dan belajar

Sumber : http://mikrotik.co.id/artikel_lihat.php?id=23


This entry was posted in Networking. Bookmark the permalink.

2 Responses to Membagi Bandwidth Lokal dan Internasional dengan Mikrotik

  1. Pingback: lgtgmcrn

  2. Hasi says:

    ada binusian ya,,,hmmm,,,thx ya info nya

Leave a Reply

Your email address will not be published. Required fields are marked *